Nomics.com Dashboard and Currency Pages Down
Incident Report for Nomics
Resolved
This incident has been resolved.
Posted Jun 11, 2019 - 14:35 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 11, 2019 - 14:31 CDT
Investigating
We are currently investigating this issue.
Posted Jun 11, 2019 - 14:29 CDT
This incident affected: Nomics.com Website.