Website not loading
Incident Report for Nomics
Resolved
This incident has been resolved. This was due to a proxy change on Netlify: https://www.netlifystatus.com/incidents/s7ymbg802yf5
Posted Feb 22, 2022 - 11:31 CST
Investigating
We are currently investigating this issue.
Posted Feb 22, 2022 - 10:50 CST
This incident affected: Nomics.com Website.